Marketplace Delivery Issues
Incident Report for Second Life
Resolved
This issue has been resolved. If you continue seeing problems with item delivery after this time, please contact Support.
Posted Nov 13, 2024 - 17:22 PST
Investigating
We are aware of issues with some Marketplace purchases not being delivered. Our engineers are investigating this issue currently. Please watch this blog for updates.
Posted Nov 12, 2024 - 11:08 PST