Second Life Login Maintainance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 06:07 PDT
Monitoring
Logins are returning to normal for both viewer and dashboard. We recommend you clear your web browser's cookie settings and Second Life viewer's cache before logging in. You can also clear your browser's cookie settings via this link: https://secondlife.com/my/account/logout.php.
Posted Jun 21, 2023 - 13:17 PDT
Investigating
We are conducting unscheduled maintenance to our login system which will prevent access to the Second Life viewer and web dashboard . We sincerely apologize for the inconvenience, and please watch this blog for updates.
Posted Jun 21, 2023 - 12:38 PDT
This incident affected: Second Life Services (Logins) and Websites (my.secondlife.com).