Login Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved. Logins have returned to normal.
Posted Aug 06, 2022 - 15:49 PDT
Investigating
We are aware that some Residents may be experiencing problems trying to log into and/or stay connected to Second Life and the Second Life website. Our engineers are actively trying to alleviate the issue.

More information will be posted to the status blog as it is available.
Posted Aug 06, 2022 - 12:23 PDT
This incident affected: Websites (secondlife.com, marketplace.secondlife.com, community.secondlife.com, wiki.secondlife.com, my.secondlife.com, feedback.secondlife.com, support.secondlife.com, search.secondlife.com, places.secondlife.com, land.secondlife.com) and Second Life Services (Logins).