Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
Phone and chat support are open again.
Posted 22 days ago. Apr 07, 2017 - 13:00 PDT
Investigating
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PDT, April 7th, 2017. Case submissions are still available.
Posted 22 days ago. Apr 07, 2017 - 11:38 PDT