Phone and Live Chat Support Maintenance

Incident Report for Second Life

Resolved

Thank you all for your patience. This issue is now resolved, and support will be returning to it usual Thursday operations.
Posted Feb 20, 2025 - 09:41 PST

Update

Thank you for your patience. We are continuing to monitor this situation. Please keep an eye on this status page for further updates. We apologize for the inconvenience.
Posted Feb 20, 2025 - 08:35 PST

Investigating

Currently, phone and live chat support is unavailable. Support tickets are still available. We are investigating the cause and will post again with updates or resolutions. We apologize for the inconvenience and appreciate your patience.
Posted Feb 20, 2025 - 07:07 PST
This incident affected: External Support (Chat Support, Phone Support).