Phone Support Outage

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Dec 10, 2021 - 13:08 PST

Investigating

Phone support is unavailable. Live chat and ticket submissions will still be available at this time.
Posted Dec 10, 2021 - 12:41 PST
This incident affected: External Support (Phone Support).