Unscheduled Login Maintenance

Incident Report for Second Life

Resolved

This matter has been resolved. Thank you for your patience!
Posted Nov 08, 2023 - 17:00 PST

Investigating

Users have reported that their account password is incorrect upon login, and we are currently investigating this matter. Users will be unable to login until the issue has been resolved. Please watch this blog for updates.
Posted Nov 08, 2023 - 16:29 PST
This incident affected: Second Life Services (Logins).