Unscheduled Beta Grid Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance for the Beta grid.
Posted 3 months ago. May 29, 2019 - 16:06 PDT
Investigating
We are currently performing unscheduled maintenance on the Beta grid. Residents will be unable to access during this time. Thank you for your patience.
Posted 3 months ago. May 28, 2019 - 16:15 PDT