Support Downtime Still in Progress
Incident Report for Second Life
Resolved
Upgrades to Our Support Portal are now complete. Live Chat along with all other forms of Support are now available. Thank you for your patience!
Posted 27 days ago. Nov 20, 2017 - 12:53 PST
Update
Our Support Portal upgrades are still in progress. During this period, Live Chat remains unavailable, but phone support is available for Concierge and Billing issues. All other issues can be resolved through a support ticket, which can be filed here:

https://lindenlab.freshdesk.com/support/tickets/new

We apologize for the inconvenience, but please monitor this blog for updates.
Posted 30 days ago. Nov 17, 2017 - 10:15 PST
Update
We are continuing to work on improvements to our Support Portal. At this time, Live Chat is not available as we continue our enhancements. Support Tickets, Billing phone and Concierge phone are still available. Please monitor this blog for updates.
Posted about 1 month ago. Nov 16, 2017 - 04:53 PST
Update
Our support portal is now available again, including Support Tickets, Billing phone and Concierge phone. At this time, Live Chat is not available as we continue our enhancements.
Posted about 1 month ago. Nov 15, 2017 - 06:14 PST
Update
We are continuing to work on improvements to our Support Portal. We are aware that https://support.secondlife.com is currently unreachable and are working to resolve that at this time. We apologize for the inconvenience, but please monitor this blog for updates.
Posted about 1 month ago. Nov 15, 2017 - 04:55 PST
Update
Thank you for your patience on this issue. At this time, Live Chat is not available as we continue our enhancements. Support Tickets, Billing phone and Concierge phone are still available.
Posted about 1 month ago. Nov 14, 2017 - 10:36 PST
Monitoring
Our scheduled maintenance from earlier is currently still in progress. We will provide updates as necessary. For more information you can visit https://status.secondlifegrid.net/incidents/2nbfxbfl57c7 .
Posted about 1 month ago. Nov 14, 2017 - 09:15 PST
This incident affected: External Support (Chat Support).