Concierge Phone Support and Live Chat Unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 25 days ago. Jan 27, 2019 - 11:04 PST
Investigating
Concierge phone and chat support will be unavailable from 10:00 AM PDT to 11:00 AM PDT today, January 27th, 2019. Ticket submissions will still be available at this time.
Posted 25 days ago. Jan 27, 2019 - 09:21 PST
This incident affected: External Support (Chat Support, Phone Support).