Skill Gaming Regions Access Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Nov 24, 2020 - 08:31 PST

Investigating

We are aware that there are some Residents experiencing access issues when attempting to enter Skill Gaming regions and we are currently investigating. Please keep an eye on this blog for any updates.
Posted Nov 24, 2020 - 08:07 PST
This incident affected: Inworld Services (Teleports).