Mesh Uploads for Premium Plus Members

Incident Report for Second Life

Resolved

Free mesh uploads for Premium Plus are now gridwide!
20 Picks for all are also now gridwide.
In order to see these changes reflected, you will need the latest Second Life Viewer release (https://secondlife.com/downloads)
Or the latest Firestorm Beta (https://www.firestormviewer.org/early-access-beta-downloads/)
However they will persist regardless of the viewer you use across logins.
Posted Mar 13, 2025 - 11:26 PDT

Update

Additional Notes:

- To take advantage of 20 profile picks, residents will need both Bluesteel regions and ForeverFPS Beta - https://releasenotes.secondlife.com/viewer/7.1.12.12999043440.html

- Firestorm Beta will support both.
Posted Feb 25, 2025 - 11:34 PST

Monitoring

Please note that free mesh uploads are currently available on the Premium Plus Sandbox—Radiantia at: http://maps.secondlife.com/secondlife/Sandbox%20Radiantia/128/128/27

This will be rolled out to the entire grid in two weeks.

To read more, please visit: https://community.secondlife.com/news/featured-news/membership-mania-week-3-big-rewards-even-bigger-perks-r11158/
Posted Feb 21, 2025 - 14:11 PST