Concierge Phone Support and Live Chat Unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 20, 2019 - 15:01 PDT
Investigating
Concierge phone and chat support will be unavailable from 10:00 AM until 3:00 PM on Saturday, April 20. Ticket submissions will still be available at this time.
Posted about 1 month ago. Apr 20, 2019 - 10:03 PDT
This incident affected: External Support (Chat Support, Phone Support).