Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 17, 2024 - 10:00 PST
Investigating
We are aware that the Marketplace is currently offline and Marketplace deliveries have been slower than typical. Our engineers are currently investigating.

We will update this blog when delays have been cleared.
Posted Dec 17, 2024 - 08:17 PST
This incident affected: Second Life Services (Marketplace Purchases).