Auctions Temporarily Offline
Incident Report for Second Life
Resolved
The land auctions are back online! You can read about the improvements here: https://community.secondlife.com/blogs/entry/2386-a-face-lift-for-auctions/
Posted 5 days ago. Jul 11, 2018 - 11:32 PDT
Identified
Land auctions for Second Life are temporarily offline while we make improvements to the auction system. Land auctions will resume as normal once the improvements have completed. Watch this space for updates as they become available.
Posted 7 days ago. Jul 09, 2018 - 12:16 PDT