Second Life Webpages Temporarily Unavailable

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jun 02, 2021 - 14:13 PDT

Investigating

We are aware that some Second Life webpages are returning errors. We are working as quickly as possible to fix it. Please check this blog for further updates.
Posted Jun 02, 2021 - 11:50 PDT
This incident affected: Websites (secondlife.com).