Unscheduled Secondlife.com Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Dec 02, 2019 - 18:36 PST

Investigating

We are currently investigating an issue with Secondlife.com. This web-page may be unavailable during this time.

Please check this blog for updates.
Posted Dec 02, 2019 - 17:20 PST
This incident affected: Websites (secondlife.com).