Unscheduled Voice Maintenance
Incident Report for Second Life
Resolved
Voice services have been restored.
Posted 5 months ago. Apr 16, 2018 - 06:40 PDT
Investigating
We are currently investigating an issue regarding voice chat. Please watch this post for further developments.
Posted 5 months ago. Apr 15, 2018 - 10:52 PDT
This incident affected: Inworld Services (Voice Chat).