Since the beginning of the year, we’ve experienced a higher volume of support tickets and system challenges that have slowed our response times. We know this isn’t what you expect from us, and we’re truly sorry for any inconvenience caused.
Our team is working hard to streamline our processes and get things back to normal as quickly as possible. We’ll keep you updated on our progress. Thank you for your patience and understanding as we work through these issues.
Posted Feb 25, 2025 - 10:06 PST
Investigating
Our Support Department is currently experiencing an unusually high volume of support contacts, including support tickets. This has resulted in longer than normal response times for some support tickets. We are working to answer these tickets as quickly as possible, and we appreciate your patience. Please watch this blog for updates.
Posted Oct 29, 2024 - 07:18 PDT
This incident affects: External Support (Case Support).