Second Life Service Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Aug 01, 2022 - 13:51 PDT

Investigating

Some Second Life services are currently experiencing difficulties. During this time, there may be some issues with Event creation.

Please monitor this blog for additional updates
Posted Aug 01, 2022 - 12:39 PDT