Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 31, 2023 - 12:58 PST
Investigating
We are currently performing unscheduled maintenance on the Second Life Marketplace. The Marketplace will be unavailable during this maintenance. Please watch this blog for updates, and have a Happy New Year!
Posted Dec 31, 2023 - 10:43 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).