Unscheduled Phone Support Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance to our Concierge and Billing phone support system is now complete.
Posted about 1 month ago. May 21, 2018 - 16:46 PDT
Investigating
We are currently performing unscheduled maintenance to our Concierge and Billing phone support system. Live Chat and Support Ticket submission remain available. Please watch this page for further updates.
Posted about 1 month ago. May 21, 2018 - 10:36 PDT
This incident affected: External Support (Phone Support).