CasperVend and CasperLet Service Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jun 24, 2024 - 06:14 PDT

Update

We are continuing to investigate this issue.
Posted Jun 21, 2024 - 13:03 PDT

Investigating

CasperVend services are currently experiencing an outage. During this time, your CasperVend and CasperLet services may be unavailable. We are working to restore them now,

Please monitor this blog for additional updates
Posted Jun 21, 2024 - 10:29 PDT