Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted about 2 months ago. Mar 29, 2019 - 11:03 PDT
Investigating
We are currently performing unscheduled maintenance on the Second Life Marketplace. The site may experience lag, unexpected time-outs or other loading issues while the maintenance is underway. We are investigating and updates will be made available here as the situation evolves.
Posted about 2 months ago. Mar 29, 2019 - 10:48 PDT
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).