Unscheduled Maintenance with Billing
Incident Report for Second Life
Resolved
The maintenance has been resolved.
Posted 12 days ago. Sep 10, 2019 - 07:28 PDT
Update
We are continuing to investigate this issue.
Posted 12 days ago. Sep 10, 2019 - 06:33 PDT
Investigating
We are currently investigating an issue affecting our billing and payments systems. While this maintenance is in progress, residents will be unable to use the cashier or make purchases. Please watch this blog for updates.
Posted 12 days ago. Sep 10, 2019 - 05:10 PDT
This incident affected: Websites (secondlife.com, marketplace.secondlife.com) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).