Second Life Login Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jan 10, 2023 - 08:44 PST

Investigating

We are aware that some Residents may be experiencing problems trying to log into and/or stay connected to Second Life. Our engineers are actively trying to alleviate the issue. We apologize for any inconvenience.

Please follow this blog for updates.
Posted Jan 10, 2023 - 08:15 PST
This incident affected: Second Life Services (Logins).