Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance on our billing system. Thank you for your patience during this time.
Posted Jul 20, 2020 - 10:46 PDT
Update
We have been made aware that one of our Payment Service Providers is undergoing unscheduled maintenance as well. Some Residents may be unable to use the cashier or to make purchases, and some purchases may take longer than normal to process. Please watch this blog for updates
Posted Jul 20, 2020 - 06:52 PDT
Investigating
We are performing unscheduled maintenance on our billing system. At this time, Residents may be unable to use the cashier or to make purchases, and some purchases may take longer than normal to process. Please watch this blog for updates.
Posted Jul 20, 2020 - 06:48 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).