Connectivity Issues to Second Life
Incident Report for Second Life
Resolved
Normal connectivity has been restored for most users. Thank you for your patience during this time.
Posted Nov 22, 2019 - 16:06 PST
Investigating
We are aware that some Residents may be experiencing problems trying to log into and/or stay connected to Second Life. Our engineers are actively trying to alleviate the issue.

More information will be posted to the status blog as it is available.
Posted Nov 22, 2019 - 12:00 PST
This incident affected: Second Life Services (Logins) and Inworld Services (Rezzing, Teleports, Inventory).