Marketplace
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 11, 2017 - 16:29 PDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Apr 11, 2017 - 16:03 PDT
This incident affected: Second Life Services (Marketplace Purchases).