My.secondlife.com Outage
Incident Report for Second Life
Resolved
The maintenance has been completed.
Posted 3 months ago. May 01, 2019 - 09:56 PDT
Investigating
My.secondlife.com is currently unavailable. While we work to bring this service back online, both my.secondlife.com and in-world profiles will be inaccessible.

We will update this blog when this web service has been restored.
Posted 3 months ago. Apr 29, 2019 - 04:23 PDT
This incident affected: Websites (my.secondlife.com) and Inworld Services (Profiles).