Login Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Sep 01, 2020 - 10:07 PDT
Update
We are continuing to investigate this issue.
Posted Sep 01, 2020 - 09:55 PDT
Investigating
We are aware that some users are currently experiencing login issues. Our engineers are currently investigating this matter. Please watch this blog for further updates.
Posted Sep 01, 2020 - 09:55 PDT
This incident affected: Second Life Services (Logins).