Payment issues for some Residents

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Dec 31, 2019 - 18:34 PST

Investigating

We are aware of issues with adding credit cards and making payments for some Residents. Our engineers are actively investigating.
Posted Dec 31, 2019 - 17:05 PST
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).