Unscheduled Subscription Issues - Premium Plus Without Stipend

Incident Report for Second Life

Resolved

Thank you for your patience! We have resolved this issue and new membership subscriptions for Premium Plus Without Stipends are once again available at secondlife.com on the Change Membership page.
Posted Oct 15, 2025 - 12:00 PDT

Identified

We're currently investigating an issue with the Premium Plus Without Stipend membership subscription option released earlier today, and have temporarily paused new sign-ups to this subscription type while we resolve the problem. Thank you for your patience and please monitor this blog for additional updates.
Posted Oct 15, 2025 - 10:57 PDT
This incident affected: Websites (secondlife.com).