Unscheduled Maintenance to the Know Your Customer Submission Form

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jul 08, 2022 - 11:08 PDT

Investigating

We are currently undergoing unscheduled maintenance to the Information Request portal. During this time residents may not be able to access the Know Your Customer submission form. Please follow this blog for updates.
Posted Jul 08, 2022 - 10:27 PDT