Unscheduled Name Change Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Feb 18, 2022 - 12:21 PST

Investigating

We are currently performing unscheduled maintenance on Name Changes. While this maintenance is in progress, Name Changes will not be available.

Please monitor this blog for additional updates
Posted Feb 18, 2022 - 12:05 PST