Unscheduled Support Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted May 11, 2020 - 14:53 PDT
Investigating
We are currently undergoing unscheduled maintenance to our Support pages at this time. While this is occurring, ticket submissions and Live Chat are not available. Residents may visit the following link to submit tickets as a guest during this period: https://lindenlab.freshdesk.com/support/home
Posted May 11, 2020 - 14:22 PDT
This incident affected: External Support (Chat Support, Case Support) and Websites (support.secondlife.com).