New Full Region Pricing Display Issue
Incident Report for Second Life
Resolved
This issue is resolved.
Posted 2 months ago. Jun 04, 2019 - 09:40 PDT
Monitoring
With today’s Full Region price reduction, new (and existing!) land owners purchasing a new Full Region may notice the old monthly pricing ($249/month) being listed further into the purchase process, or after the land has already been purchased, instead of the newly updated pricing ($229/month).

This is only a display issue, and will be corrected within 24 hours.

For additional information on the Full Region price reduction, please see https://community.secondlife.com/blogs/entry/2557-land-price-reductions-new-premium-perks-and-pricing-changes/
Posted 2 months ago. Jun 03, 2019 - 15:17 PDT