Unscheduled Destination Guide Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted May 13, 2020 - 13:22 PDT

Investigating

We are currently undergoing an unscheduled maintenance on our Destination Guide at this time. While this is occurring, Residents may not be able to load the Destination Guide. Please monitor this post for updates.
Posted May 13, 2020 - 10:52 PDT