Unscheduled Maintenance with Profiles

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Dec 02, 2019 - 13:53 PST

Investigating

We are aware of a current issue of profiles being down. We apologize for the inconvenience, and are investigating the issue. Please keep an eye on this blog post for any updates.
Posted Dec 02, 2019 - 12:51 PST
This incident affected: Websites (my.secondlife.com).