Unscheduled Billing Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Feb 05, 2021 - 14:03 PST

Investigating

We are aware that some Linden$ purchases are taking longer than normal to process, and we are monitoring the issue. Please follow this blog for updates.
Posted Feb 05, 2021 - 12:46 PST
This incident affected: Second Life Services (LindeX Purchases).