Unscheduled Maintenance on Feedback.secondlife.com

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 12:23 PDT

Investigating

We are currently performing unscheduled maintenance on the feedback portal. During this time, submissions to the feedback portal may be unavailable. Please watch this blog for updates.
Posted Aug 21, 2025 - 08:50 PDT
This incident affected: Websites (feedback.secondlife.com).