Unscheduled Community Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Aug 25, 2021 - 13:38 PDT
Investigating
We are currently undergoing maintenance to the Community pages. At this time residents may not be able to access the Community Blog or Forum. Please follow this blog for any further updates.
Posted Aug 25, 2021 - 13:34 PDT
This incident affected: Websites (community.secondlife.com).