Linden Realms Maintenance
Incident Report for Second Life
Resolved
This maintenance has been completed.
Posted about 1 year ago. Oct 14, 2018 - 11:24 PDT
Investigating
We are currently investigating an issue in Linden Realms where Linden $ payouts are failing. During this maintenance, Residents will not be able to access Linden Realms. Please keep an eye on this blog for further updates as they become available.
Posted about 1 year ago. Oct 11, 2018 - 18:59 PDT