Unscheduled Event Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jan 10, 2020 - 11:27 PST

Investigating

We are aware of an issue preventing new events from being created. During this time, residents may receive an error when creating new events. Please watch this blog for updates.
Posted Jan 10, 2020 - 10:58 PST