Unscheduled Phone Support Maintenance
Incident Report for Second Life
Resolved
Phone support maintenance has been completed.
Posted Aug 30, 2023 - 09:01 PDT
Investigating
Phone support is currently undergoing unscheduled maintenance. Some callers may experience disconnects, or issues connecting to our phone lines.
Posted Aug 30, 2023 - 06:49 PDT
This incident affected: External Support (Phone Support).