Second Life Support Outage
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 18, 2021 - 08:51 PST
Update
We are continuing to investigate this issue.
Posted Dec 18, 2021 - 08:42 PST
Investigating
We are currently investigating the outage of our Support services. At this time residents may experience issues accessing their Support History, and the ability to access Live Chat or to submit a Support case. We greatly apologize for this inconvenience. Please follow this blog for any further updates.
Posted Dec 18, 2021 - 08:37 PST
This incident affected: External Support (Chat Support, Phone Support, Case Support) and Websites (support.secondlife.com).