Unscheduled Voice Server Maintenance
Incident Report for Second Life
Resolved
The Voice Server Maintenance has been completed.
Posted 7 months ago. May 07, 2018 - 13:22 PDT
Investigating
We are currently aware of an issue affecting in world voice. We appreciate your patience while we investigate this issue.
Posted 7 months ago. May 07, 2018 - 11:46 PDT
This incident affected: Inworld Services (Voice Chat, Group Voice Chat).