Unscheduled Profile Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 08, 2019 - 11:58 PST
Investigating
We are currently performing unscheduled profile maintenance. During this time some users may experience issues viewing and editing profiles. Please check this blog for updates.
Posted about 1 month ago. Feb 07, 2019 - 13:38 PST
This incident affected: Websites (my.secondlife.com).