Unscheduled Profile Maintenance
Incident Report for Second Life
Resolved
Maintenance on profiles has successfully completed. Profiles should now be fully available.
Posted 5 months ago. Jun 26, 2018 - 14:11 PDT
Investigating
We are currently performing unscheduled profile maintenance. During this time some users may experience issues viewing and editing profiles. Please check this blog for updates.
Posted 5 months ago. Jun 26, 2018 - 10:08 PDT
This incident affected: Websites (my.secondlife.com).