Marketplace Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Feb 19, 2023 - 07:27 PST

Investigating

We are currently aware of some Marketplace issues with deliveries. We are working to correct these issues as quickly as possible. We appreciate your patience and understanding while we work towards a resolution.
Posted Feb 19, 2023 - 06:49 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).